Opened 8 years ago

Closed 5 years ago

#1071 closed feature (wontfix)

SMPD.exe does not support UNICODE computer-names on XP

Reported by: cgl_lgs@… Owned by: jayesh
Priority: major Milestone: future
Component: mpich Keywords: SMPD computer-name
Cc:

Description (last modified by balaji)

but it can work normally in WIN7!

Change History (10)

comment:1 in reply to: ↑ description Changed 8 years ago by cgl_lgs@…

for example:
computer-name:
在这里.here.com.

mpiexec -n 2 cpi.exe
will not run

and the computer-name in some function will being:
在这里.here.c
lost 3 character:)

u can find "GetComputerNameEx?" in src:) I think it's usefull:)

comment:2 follow-up: Changed 8 years ago by jayesh

  • Owner set to jayesh
  • Status changed from new to accepted
  • Summary changed from SMPD.exe is not support UNICODE computer-name on XP to SMPD.exe does not support UNICODE computer-names on XP

comment:3 in reply to: ↑ 2 Changed 8 years ago by cgl_lgs@…

Replying to jayesh:
program:

cpi.exe

exam. 1:

env. "SMPD_INTERFACE_HOSTNAME" not set.
run "mpiexec -n 1 cpi.exe".
timeout when call MPI_INIT.
(I think the problem is in function SMPDU_Sock_get_host_description)

exam. 2:

env. "SMPD_INTERFACE_HOSTNAME"="127.0.0.1".
run "mpiexec -n 1 cpi.exe".
everything is ok.

exam. 3:

env. "SMPD_INTERFACE_HOSTNAME"="127.0.0.1".
run "mpiexec -n 2 cpi.exe".
the program will suspend when calling MPI_BCAST.

comment:4 follow-up: Changed 8 years ago by jayesh

  • Milestone changed from mpich2-1.3 to mpich2-1.3.1
  • Type changed from bug to feature

Hi,

SMPD does not support UNICODE hostnames now. To support unicode hostnames, we need to change the current wire protocol (used for communication btw SMPD daemons) to support UNICODE.
PMI2 - refer http://wiki.mcs.anl.gov/mpich2/index.php/PMI_v2_Wire_Protocol - (SMPD currently supports PMI1) clearly defines a wire protocol that supports UNICODE characters.
To support this feature we need to add support for PMI2 (unlikely for SMPD) or add support for UNICODE alone (likely to be the course of action) to SMPD.

Regards,
Jayesh

comment:5 in reply to: ↑ 4 Changed 8 years ago by cgl_lgs@…

Hi,
I see, thx:)I'll waiting for U:)
Replying to jayesh:

Hi,

SMPD does not support UNICODE hostnames now. To support unicode hostnames, we need to change the current wire protocol (used for communication btw SMPD daemons) to support UNICODE.
PMI2 - refer http://wiki.mcs.anl.gov/mpich2/index.php/PMI_v2_Wire_Protocol - (SMPD currently supports PMI1) clearly defines a wire protocol that supports UNICODE characters.
To support this feature we need to add support for PMI2 (unlikely for SMPD) or add support for UNICODE alone (likely to be the course of action) to SMPD.

Regards,
Jayesh

comment:6 Changed 8 years ago by jayesh

  • Milestone changed from mpich2-1.3.2 to mpich2-1.3.3

comment:7 Changed 7 years ago by balaji

  • Milestone changed from mpich2-1.3.3 to mpich2-1.4

Milestone mpich2-1.3.3 deleted

comment:8 Changed 7 years ago by balaji

  • Milestone changed from mpich2-1.4 to future

comment:9 Changed 5 years ago by balaji

  • Description modified (diff)
  • Status changed from accepted to new

comment:10 Changed 5 years ago by balaji

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.