Opened 7 years ago

Closed 5 years ago

#1577 closed bug (wontfix)

MPICH2 Credentials rejected

Reported by: paul.hart@… Owned by: jayesh
Priority: major Milestone: future
Component: mpich Keywords:
Cc:

Description (last modified by balaji)

I am having trouble running an mpi application using MPICH2. I get the error "Credentials for USA\A017443 rejected connecting to staap1467d.usa.x".

I have run "mpiexec -register", registered the username and password. Running "mpiexec -validate" returns "SUCCESS".

The server is running Windows 2008 Server R2 Enterprise.

Change History (12)

comment:1 Changed 7 years ago by jayesh

Hi,

Did you follow the instructions in Section 9.4 (NOT 9.1) of the MPICH2 installer's guide to install MPICH2 (If not, please uninstall your existing version and re-install following the instruction in 9.4)?
Let us know if you still have issues.

Regards,
Jayesh

comment:2 Changed 7 years ago by paul.hart@…

I removed MPICH2 (MPICH2-1.2.1p1) using the msi file. I then reinstalled it using the msiexec command shown in section 9.4. When installing it in this way it still ran the gui installation interface. I restarted the server and verified smpd was running.

I then attempted to run an mpi job. It asked me for credentials, for "account" I hit "enter". For "password" I entered my user password. I then got the credentials error.

comment:3 Changed 7 years ago by paul.hart@…

I am running everything via an Adminstrator command prompt. I used mpiexec to register the user name and password. I then validated it (SUCCESS). Tried to run an mpi job and again got the credentials error. Could this be caused by some server security setting?

comment:4 Changed 7 years ago by jayesh

  • Owner set to jayesh
  • Status changed from new to accepted

What is the exact error message that you get (copy-paste the command and the output from the command prompt)?

-Jayesh

comment:5 Changed 7 years ago by paul.hart@…

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\A017443\Desktop>msiexec /x mpich2-1.2.1p1-win-x86-64.msi

C:\Users\A017443\Desktop>msiexec /x mpich2-1.2.1p1-win-x86-64.msi

C:\Users\A017443\Desktop>cd ..

C:\Users\A017443>cd Downloads

C:\Users\A017443\Downloads>msiexec /I mpich2-1.2.1p1-win-x86-64.msi

C:\Users\A017443\Downloads>d:

D:\FDS\cabletray2M>mpiexec -file mpiconfig.txt
User credentials needed to launch processes:
account (domain\user) [USA\A017443]:
password:
Credentials for USA\A017443 rejected connecting to STAAP1467D.usa.xl
Aborting: Unable to connect to STAAP1467D.usa.xl

D:\FDS\cabletray2M>mpiexec -file mpiconfig.txt
User credentials needed to launch processes:
account (domain\user) [USA\A017443]:
password:
Credentials for USA\A017443 rejected connecting to STAAP1467D.usa.xl
Aborting: Unable to connect to STAAP1467D.usa.xl

D:\FDS\cabletray2M>mpiexec -register
account (domain\user) [USA\A017443]:
password:
confirm password:
Password encrypted into the Registry.

D:\FDS\cabletray2M>mpiexec -validate
SUCCESS

D:\FDS\cabletray2M>mpiexec -file mpiconfig.txt
Credentials for USA\A017443 rejected connecting to STAAP1467D.usa.xl
Aborting: Unable to connect to STAAP1467D.usa.xl

D:\FDS\cabletray2M>

USA\A017443 is the user. STAAP1467D.usa.xl is the server name.

comment:6 Changed 7 years ago by jayesh

Can you try running your job without using the config file (mpiexec -n 2 hostname)?

-Jayesh

comment:7 Changed 7 years ago by paul.hart@…

D:\FDS\cabletray2M>mpiexec -n 2 -host STAAP1467D.usa.xl D:\FDS\cabletray2M\fds5_
mpi_win_64.exe cable_tray.fds
Credentials for USA\A017443 rejected connecting to STAAP1467D.usa.xl
Aborting: Unable to connect to STAAP1467D.usa.xl

D:\FDS\cabletray2M>

comment:8 Changed 7 years ago by jayesh

It looks that the registered credentials (username/password) are not valid on the host (STAAP1467D.usa.xl) you are trying to run your job.

-Jayesh

comment:9 Changed 7 years ago by paul.hart@…

What is interesting is that I am logging on to the STAAP1467D.usa.xl server using the same credentials. I am meeting with my IT dept later today to hopefully figure this out. I will let you know what I find.

comment:10 Changed 6 years ago by balaji

  • Milestone set to future
  • Status changed from accepted to assigned

comment:11 Changed 6 years ago by paul.hart@…

Several actions were taken, one of which probably fixed the problem.

Background
Individual users were given admin access through the use of specific user Groups in Server 2008.

Actions Taken:

  • The Groups were added to the permissions for the data drive being used (given RW access)
  • The data drive was change from read only (it appeared it defaulted to read only).

comment:12 Changed 5 years ago by balaji

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.