Opened 6 years ago

Closed 5 years ago

#1580 closed bug (wontfix)

Program compiled with MPICH2 32-bit + gfortran does not work on Windows

Reported by: jayesh Owned by: jayesh
Priority: major Milestone: future
Component: mpich Keywords:
Cc: hcassid2@…

Description (last modified by balaji)

Programs compiled with gfortran does not work as expected on Windows.
When run without mpiexec it works, but does not not produce any output (just comes back to command prompt) when launched with mpiexec.

-Jayesh

No effect, still not producing any output.

On 2/27/2012 2:36 PM, Jayesh Krishna wrote:
> Hi,
>   Please follow the steps below and let us know the results,
>
> # Rename c:\Program Files\MPICH2\lib\libfmpich2g.a to c:\Program Files\MPICH2\lib\libmpifmpich2g.a
> # Re-compile your code as follows,
>
>    gfortran -o fpi fpi.f -lmpifmpich2g -lmpi
>
> # Re-run fpi with/without mpiexec and let us know the results.
>
> Regards,
> Jayesh
>
> ----- Original Message -----
> From: "Hugh Cassidy"<hcassid2@uwo.ca>
> To: "Jayesh Krishna"<jayesh@mcs.anl.gov>
> Cc: mpich-discuss@mcs.anl.gov
> Sent: Monday, February 27, 2012 12:50:58 PM
> Subject: Re: [mpich-discuss] Compiled applications working standalone, but not using mpiexec
>
> Hello,
> -localonly option has no effect - no output is produced.
>
> I am able to compile and run successfully the icpi.c example, however,
> which leads me to believe the problem is related to compiling fortran
> code specifically.
>
> I'm running MinGW, using GNU Fortran version 4.6.1. To compile fpi.f, I
> execute the following command:
> gfortran -o fpi fpi.f -lfmpich2g
>
> Which successfully compiles the program. I've read that there is an
> issue using the windows installer and fortran, since the libraries are
> compiled with the intel fortran compiler - is this correct?
>
> On 2/27/2012 11:33 AM, Jayesh Krishna wrote:
>> Hi,
>>    Try running your job with the "-localonly" option and see if it prints an error message.
>>
>> Regards,
>> Jayesh
>>
>> ----- Original Message -----
>> From: "Hugh Cassidy"<hcassid2@uwo.ca>
>> To: mpich-discuss@mcs.anl.gov
>> Sent: Sunday, February 26, 2012 4:41:48 PM
>> Subject: [mpich-discuss] Compiled applications working standalone,        but not using mpiexec
>>
>> Hello,
>> I have MPICH2 32 installed on Windows 7. The cpi.exe example works fine
>> when I run, for example, the command:
>> mpiexec -n 4 cpi.exe
>>
>> I have been able to compile, using gfortran, the fpi.f example.
>> Furthermore, I can run the generate application in a standalone fashion:
>> fpi.exe
>>
>> However, when I attempt to use mpiexec, it doesn't work:
>> mpiexec -n 4 fpi.exe
>> Doesn't seem to do anything - I'm just returned immediately to the
>> command prompt with no output displayed. Does anyone know why this may
>> be happening? I'm experiencing the same problem trying to run another
>> application that makes use of mpi - it runs standalone, but not using
>> the mpiexec command. I'm guessing this means there is some problem with
>> the compilation step?
>>
>> Thanks!

Change History (2)

comment:1 Changed 6 years ago by mustafa.mohamed46@…

I want to program with mpi i have already install mpich2 but the missing step i faced is compiling ... i want to work with writing C codes .. so if you can help me i will be thanks for you ... Regards

comment:2 Changed 5 years ago by balaji

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.