Opened 6 years ago

Closed 5 years ago

#1646 closed bug (wontfix)

MPICH2 not working in Windows 7?

Reported by: redNinja1923@… Owned by:
Priority: major Milestone: future
Component: mpich Keywords: mpiexec not working
Cc:

Description (last modified by balaji)

Hello,

I have tried running MPI with OpenMPI but it wouldn't work so I switched to MPICH2. My code complies fine in Windows using Visual Studio 2010 but when I go to invoke mpiexec -n 2 TEST.exe it runs for some time then crashes with the error:

Error while connecting to host, A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond. (10060)
Connect on sock (host=BAHR83M5Z8.resource.ds.bah.com, port=8676) failed, exhause
d all end points
Unable to connect to 'BAHR83M5Z8.resource.ds.bah.com:8676',
sock error: Error = -1

I have tried every thing I could to get mpiexec to run some simple MPI code on my system but have had no luck. I've posted on other forums but no one answers. Help! I don't know how else to run MPI code in Windows because nothing seems to be working for me (And I've tried seems like everyone's potential solutions already but no luck still). They would all say "This SHOULD work" on their solutions but its not in my case. Also mpiexec seems to just hang when I ran my code with OpenMPI (do you know the potential reason?).

Thanks

Change History (2)

comment:1 Changed 6 years ago by balaji

  • Milestone set to future

comment:2 Changed 5 years ago by balaji

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.