Opened 6 years ago

Closed 6 years ago

#1660 closed bug (invalid)

MPI_AINT incorrect size

Reported by: artem.v.yalozo@… Owned by: jayesh
Priority: major Milestone: future
Component: mpich Keywords:
Cc:

Description

There seems to be incorrect MPI_AINT definition in mpi.h for x64 architecture on Windows (4 bytes):
#define MPI_AINT ((MPI_Datatype)0x4c000443)

It should be (8 bytes):
#define MPI_AINT ((MPI_Datatype)0x4c000843)

The definition is incorrect as MPI_AINT is a pointer which size is given by:
#define MPID_Datatype_get_basic_size(a) (((a)&0x0000ff00)>>8)

There is no such issue on Linux.

Change History (5)

comment:1 Changed 6 years ago by jayesh

  • Owner set to jayesh
  • Status changed from new to accepted

Hi,

Can you provide additional information on your issue (Which version of MPICH2 are you using? etc)?
I do not see the issue on an installation of MPICH2 1.4.1p1 x64 version on a test machine here.

Regards,
Jayesh

comment:2 Changed 6 years ago by balaji

  • Milestone set to future

comment:3 Changed 6 years ago by artem.v.yalozo@…

The issue is relevant for the Intel MPI Library which uses winconfigure from MPICH2 1.4.1p1.
We will check if there is incorrect usage of the latter on our side.

comment:4 Changed 6 years ago by artem.v.yalozo@…

The problem was in Intel MPI Library. The ticket could be closed.

comment:5 Changed 6 years ago by thakur

  • Resolution set to invalid
  • Status changed from accepted to closed
Note: See TracTickets for help on using tickets.