Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#2215 closed bug (fixed)

automake bug #18744

Reported by: blocksom Owned by: Wesley Bland <wbland@…>
Priority: major Milestone: future
Component: mpich Keywords:
Cc: jhammond

Description

The mpich project is approaching a size where the number of files will expose a bug in release 1.14, and all previous versions of automake. When this happens the ‘make’ command will fail with the following error:

$ make
make  all-recursive
make[1]: Entering directory '/project/mpich/stage'
make[1]: execvp: /bin/sh: Argument list too long
Makefile:33338: recipe for target 'all-recursive' failed
make[1]: *** [all-recursive] Error 127
make[1]: Leaving directory '/project/mpich/stage'
make: *** [all] Error 2

The automake bug has been reported ...

http://lists.gnu.org/archive/html/bug-automake/2014-10/msg00009.html
http://debbugs.gnu.org/cgi/bugreport.cgi?bug=18744

... fixed in the master branch of the automake project ...

http://git.savannah.gnu.org/cgit/automake.git/commit/?id=e7c14d967b5bfa587c4a9fc847126b39198b7463

... and now fixed in the latest release of automake (1.15):

http://lists.gnu.org/archive/html/automake/2015-01/msg00005.html

The question for the *mpich* project is what to do when the project size passes this automake “bug threshold”? Can the autogen.sh script patch automake on-the-fly as it does with libtool? Do we simply require automake v1.15? How do the project experts want to handle this?

As I understand it, the problem is related to the total number of (source) files used per Makefile. Adding new source files - I'm not sure exactly how many - will tip us over the edge.

Change History (3)

comment:1 Changed 4 years ago by jhammond

  • Cc jhammond added

I hit this bug today trying to build MPICH on a Linux workstation. The threshold has already been met.

comment:2 Changed 4 years ago by Wesley Bland <wbland@…>

  • Owner set to Wesley Bland <wbland@…>
  • Resolution set to fixed
  • Status changed from new to closed

In 67577443f839be953e7c9c9dfd53c06cbd08525f:

require automake >= 1.15

Fixes a potential "arg list too long" error at make time. See
https://lists.gnu.org/archive/html/bug-automake/2014-10/msg00009.html
for more info. Closes #2215

Signed-off-by: Wesley Bland <wbland@…>

comment:3 Changed 3 years ago by Antonio J. Pena <apenya@…>

In 8ac6607db3a087cc8986d8124cab2b0930ae31ae:

require automake >= 1.15

Fixes a potential "arg list too long" error at make time. See
https://lists.gnu.org/archive/html/bug-automake/2014-10/msg00009.html
for more info. Closes #2215

Signed-off-by: Wesley Bland <wbland@…>

Note: See TracTickets for help on using tickets.