Opened 5 years ago

Closed 5 years ago

#449 closed bug (fixed)

ROMIO: free keyvals inside cleanup routines registered to run at MPI_Finalize()

Reported by: Lisandro Dalcin <dalcinl@…> Owned by: robl
Priority: minor Milestone: mpich2-1.1b1
Component: romio Keywords:
Cc:

Description

When running this simple example,

#include <mpi.h>
int main( int argc, char ** argv ) {
  MPI_File fh;
  int amode = MPI_MODE_RDWR | MPI_MODE_CREATE | MPI_MODE_DELETE_ON_CLOSE;
  MPI_Init(&argc, &argv);
  MPI_File_open(MPI_COMM_WORLD, "/tmp/datafile",
                amode, MPI_INFO_NULL, &fh);
  MPI_File_close(&fh);
  MPI_Finalize();
  return 0;
}

I'm still getting these warnings ...

$ ./a.out
In direct memory block for handle type ATTRIBUTE KEY, 2 handles are
still allocated

Please review the attached patch fixing the issues. Note however that
my patch is missing something ...
Please, take a look at routine:

file: src/mpi/romio/adio/common/cb_config_list.c
func: ADIOI_cb_gather_name_array()

In that function, a keyval is created and never freed. Not sure the
best way to fix it.

Regards,


--
Lisandro Dalcín
---------------
Centro Internacional de Métodos Computacionales en Ingeniería (CIMEC)
Instituto de Desarrollo Tecnológico para la Industria Química (INTEC)
Consejo Nacional de Investigaciones Científicas y Técnicas (CONICET)
PTLC - Güemes 3450, (3000) Santa Fe, Argentina
Tel/Fax: +54-(0)342-451.1594

Attachments (1)

ROMIO_FREE_KEYVALS.diff (1.4 KB) - added by Lisandro Dalcin 5 years ago.
Added by email2trac

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by Lisandro Dalcin

Added by email2trac

comment:1 Changed 5 years ago by Lisandro Dalcin

  • id set to 449

This message has 1 attachment(s)

comment:2 Changed 5 years ago by goodell

  • Component changed from mpich2 to romio
  • Milestone set to mpich2-1.1b1
  • Priority changed from major to minor
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from ROMIO: free keyvals inside cleanup routines registered to run at MPI_Finalize() to ROMIO: free keyvals inside cleanup routines registered to run at MPI_Finalize()

Hi Lisandro,

Thanks for the bug report. We are aware of this particular problem and I believe it is actually being worked on right now (see ticket #222).

Closing this ticket as a duplicate of #222.

-Dave

comment:3 Changed 5 years ago by Robert Latham

On Wed, Mar 11, 2009 at 09:06:48PM -0000, mpich2 wrote:
> -------------------------------------------------+--------------------------
>  Reporter:  Lisandro Dalcin <dalcinl@gmail.com>  |        Owner:
>      Type:  bug                                  |       Status:  closed
>  Priority:  minor                                |    Milestone:  mpich2-1.1b1
> Component:  romio                                |   Resolution:  duplicate
>  Keywords:                                       |
> -------------------------------------------------+--------------------------
>
> Changes (by goodell):
>
>   * status:  new => closed
>   * component:  mpich2 => romio
>   * summary:  ROMIO: free keyvals inside cleanup routines registered to run
>               at
>         MPI_Finalize() => ROMIO: free keyvals inside cleanup
>               routines registered to run at
>               MPI_Finalize()
>   * priority:  major => minor
>   * milestone:  => mpich2-1.1b1
>   * resolution:  => duplicate
>
> Comment:
>
>  Hi Lisandro,
>
>  Thanks for the bug report.  We are aware of this particular problem and I
>  believe it is actually being worked on right now (see ticket #222).
>
>  Closing this ticket as a duplicate of #222.

Hi Dave. This is slightly different I think. In particular, the
attributes for the cb_config_list are not addressed in #222.

==rob

--
Rob Latham
Mathematics and Computer Science Division    A215 0178 EA2D B059 8CDF
Argonne National Lab, IL USA                 B29D F333 664A 4280 315B

comment:4 Changed 5 years ago by goodell

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Fair enough, my misunderstanding. Reopening.

comment:5 Changed 5 years ago by goodell

  • Owner set to robl
  • Status changed from reopened to new

comment:6 Changed 5 years ago by robl

  • Status changed from new to assigned

comment:7 Changed 5 years ago by robl

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.